langsung saja buat scriptnya
##Script Limitasi Dinamis Simple Queue #
##Oleh NANO #http://tekhnisi-it.blogspot.com
##Feel free to share without remove the source :) #
##-------------------------------------------#
:local BWup; ##variabel total BW upload
:local BWdown; ##variabel total BW download
:local hasilup; ##variabel hasil BW upload/jumlah on
:local hasildown; ##variabel hasil BW download/jumlah on
:global jumlah;
:local ipatas;
:local ipbawah;
##---Sesuaikan nilai variabel dibawah ini dengan nilai
##---90% * Jumlah BWup dan 90% * Jumlah BWdown
##---Contoh ADSL 3Mbps Down/ 512Kbps up.
##---90% nya kurang lebih 2700 Down / 460 up.
##---BWup
:set BWup 460;
:set BWdown 2700;
##---Sesuaikan nilai variabel dibawah ini dengan kondisi jaringan
##---range ip bilik terkecil - terbesar
##---contoh: 192.168.1.2 - 192.168.1.20, maka ambil 2 untuk nilai ipbawah dan 20 untuk nilai ipatas
:set ipbawah 2;
:set ipatas 20;
##---------------------------------------------------------------##
##---PERHATIAN---
##---Jangan mengubah script dibawah ini.
:set jumlah 0;
:for i from=$ipbawah to=$ipatas do={
##cek respon
:if ([/ping "192.168.1.$i" count=1] = 1) do={
:set jumlah ($jumlah+1)};
};
/log warning message="Online: $jumlah";
##setting BW
:set hasilup ($BWup/$jumlah);
:set hasildown ($BWdown/$jumlah);
/log warning message="BW up: $hasilup Kbps";
/log warning message="BW down: $hasildown Kbps";
:set hasilup ($hasilup*1024);
:set hasildown ($hasildown*1024);
/queue simple set [find comment="client"] max-limit="$hasilup/$hasildown"
};
##Sekian##
cuma kayak gitu sih..habis mo dengan cara apa?pernah saya sampaikan ke mikrotik...untuk memberikan modul address list di simple queue balum di respon
##Oleh NANO #http://tekhnisi-it.blogspot.com
##Feel free to share without remove the source :) #
##-------------------------------------------#
:local BWup; ##variabel total BW upload
:local BWdown; ##variabel total BW download
:local hasilup; ##variabel hasil BW upload/jumlah on
:local hasildown; ##variabel hasil BW download/jumlah on
:global jumlah;
:local ipatas;
:local ipbawah;
##---Sesuaikan nilai variabel dibawah ini dengan nilai
##---90% * Jumlah BWup dan 90% * Jumlah BWdown
##---Contoh ADSL 3Mbps Down/ 512Kbps up.
##---90% nya kurang lebih 2700 Down / 460 up.
##---BWup
:set BWup 460;
:set BWdown 2700;
##---Sesuaikan nilai variabel dibawah ini dengan kondisi jaringan
##---range ip bilik terkecil - terbesar
##---contoh: 192.168.1.2 - 192.168.1.20, maka ambil 2 untuk nilai ipbawah dan 20 untuk nilai ipatas
:set ipbawah 2;
:set ipatas 20;
##---------------------------------------------------------------##
##---PERHATIAN---
##---Jangan mengubah script dibawah ini.
:set jumlah 0;
:for i from=$ipbawah to=$ipatas do={
##cek respon
:if ([/ping "192.168.1.$i" count=1] = 1) do={
:set jumlah ($jumlah+1)};
};
/log warning message="Online: $jumlah";
##setting BW
:set hasilup ($BWup/$jumlah);
:set hasildown ($BWdown/$jumlah);
/log warning message="BW up: $hasilup Kbps";
/log warning message="BW down: $hasildown Kbps";
:set hasilup ($hasilup*1024);
:set hasildown ($hasildown*1024);
/queue simple set [find comment="client"] max-limit="$hasilup/$hasildown"
};
##Sekian##
0 Response to "Pembagian Bandwitdh secara otomatis(dinamis) di jaringan Lokal"
Post a Comment
Ilmu ibarat sempax, kita harus menggunakannya, tapi tak perlu memamerkannya..".Tolong klik iklan dong..biar blog nya tetep eksis..Thxs "